Instalar Beryl en SuSE 10.2

Para todos los que no sepan cómo instalar Beryl en SuSE 10.2 aquí una pequeña guía de instalación.
Primero que nada deben saber que hay varias formas para usar beryl, puede ser usando AIGLX, otra es usando Xorg 7, usando las características de aceleración de una tarjeta Nvidia o usando XGL.
La forma que describiré aquí es usando XGL, dado que SuSE 10.2 ya lo trae instalado y no hay que hacer gran cosa.

Una vez que ya tenemos funcionando el XGL vamos al Centro de Control YaST y seleccionamos el icono de Cambiar Fuente de instalación. Allí agregaremos una fuente de instalación con las siguientes características:
Protocolo: http
Servidor: software.opensuse.org
Directorio en el servidor: download/X11:/XGL/openSUSE_10.2/
Damos aceptar y ahora vamos de nuevo al centro de control de YaST donde seleccionaremos Instalar/Desintalar Software.

Allí instalaremos los siguientes paquetes (solo ponemos buscar y los seleccionamos):
* xgl (Actualizar)
* compiz (Actualizar)
* beryl-core-snapshot
* beryl-plugins-snapshot
* emerald-snapshot : window decorator
* emerald-themes-snapshot
* aquamarine-snapshot
* beryl-settings-snapshot
* beryl-manager-snapshot

Ahora, si no tenemos activado XGL lo activamos:
Como root en una consola: gnome-xgl-switch –enable-xgl (Si estas en gnome lo puedes hacer desde el centro de control, efectos de escritorio)
Reiniciamos el gestor gráfico (salimos de sesión y nos volvemos a logear)
Ahora solo tecleamos lo siguiente como superusuario:
beryl-manager
Y listo, tenemos Beryl corriendo en nuestro SuSE.

Para iniciarlo automáticamente al inicio de sesión:
En KDE
Como superusuario escribimos:
ln -s /usr/bin/beryl-manager ~/.kde/Autostart/beryl-manager
ln -s /usr/bin/beryl ~/.kde/Autostart/beryl

En Gnome
Vamos a Centro de control -> Sesiones
y en el cuadro de diálogo seleccionamos la pestaña Progrmas de inicio, agregamos allí beryl-manager y listo.

Espero esta miniguía les sea útil, cualquier duda o comentario son bien venidos.

Anuncios
Acerca de

Estudiante de la Facultad de Ciencias UNAM, desde hace unos años. Soñador y loco, enamorado...

Publicado en Linux
11 comments on “Instalar Beryl en SuSE 10.2
  1. pikela dice:

    mastercard and visa student cards 2

  2. Carlos Arzate dice:

    Yo tengo una tarjeta ATI y mi PC se traba a cada rato desde que instale el Compiz, necesito un driver para las ATI?

  3. abunaineko dice:

    Así es, necesitas instalar el driver propietario de ati, checa la página oficial de AMD y ve a la subsección de ATI, encontrarás un instalador muy sencillo de utilizar para instalar el driver.

  4. jcho360 dice:

    buenas buenas, ante mano gracias por publicar una guia para la ayuda d los q no sabemos mucho jeje, pero necesito una manito extra para poder instalar el berryl, antes tenia el compiz y todo bien fino, pero ahora toy tratando d instalar el beryl y mas problemas no me ha podido dar, cuando trato d instalar los paquetes de beryl o d aquamarine o emerald me lanza error.tengo el suse 10.2 aqui les pego una parte de los errores ya q son demasiados… MUCHAS GRACIAS D ANTEMANO
    #### YaST2 conflicts list – generated 2007-05-23 14:08:42 ####

    3ddiag-0.735-1.5.i586 no se puede instalar debido a dependencias que no están presentes
    No hay proveedores instalables de libhd.so.12 para 3ddiag-0.735-1.5.i586
    Resolución de conflictos:
    ( ) suprimir 3ddiag
    ( ) Omitir este requisito sólo aquí
    banshee-engine-gst-0.10.9-26.38.i586 no se puede instalar debido a dependencias que no están presentes
    No hay proveedores instalables de banshee == 0.10.9 para banshee-engine-gst-0.10.9-26.38.i586
    Resolución de conflictos:
    ( ) suprimir banshee-engine-gst
    ( ) Omitir este requisito sólo aquí
    banshee-plugins-default-0.10.9-26.38.i586 no se puede instalar debido a dependencias que no están presentes
    No hay proveedores instalables de banshee == 0.10.9 para banshee-plugins-default-0.10.9-26.38.i586
    Resolución de conflictos:
    ( ) suprimir banshee-plugins-default
    ( ) Omitir este requisito sólo aquí
    beagle-evolution-0.2.3-40.30.i586 no se puede instalar debido a dependencias que no están presentes
    No hay proveedores instalables de mono(BeagleDaemonLib) == 1.9.0.0 para beagle-evolution-0.2.3-40.30.i586
    Resolución de conflictos:
    ( ) suprimir beagle-evolution
    ( ) Omitir este requisito sólo aquí
    beagle-gui-0.2.3-40.30.i586 no se puede instalar debido a dependencias que no están presentes
    No hay proveedores instalables de mono(Beagle) == 0.0.0.0 para beagle-gui-0.2.3-40.30.i586
    Resolución de conflictos:
    ( ) suprimir beagle-gui
    ( ) Omitir este requisito sólo aquí
    beryl-core-0.2-6.12.i586[20070522-224428] no se puede instalar debido a dependencias que no están presentes
    No hay proveedores instalables de libxcb.so.1 para beryl-core-0.2-6.12.i586[20070522-224428]
    Resolución de conflictos:
    ( ) no instalar beryl-core
    ( ) Omitir este requisito sólo aquí
    beryl-core-snapshot-r4338-2.14.i586[20070522-224428] entra en conflicto con otras resoluciones
    beryl-core-snapshot-r4338-2.14.i586[20070522-224428] está en conflicto con: beryl-plugins-0.2-3.11.i586[20070522-224428]
    Resolución de conflictos:
    ( ) no instalar beryl-core-snapshot
    ( ) no instalar beryl-plugins
    ( ) Omitir este conflicto de beryl-core-snapshot
    beryl-core-snapshot-r4338-2.9.i586[20070523-125913] entra en conflicto con otras resoluciones
    beryl-core-snapshot-r4338-2.9.i586[20070523-125913] está en conflicto con: beryl-plugins-0.2-3.11.i586[20070522-224428]
    Resolución de conflictos:
    ( ) no instalar beryl-core-snapshot
    ( ) no instalar beryl-plugins
    ( ) Omitir este conflicto de beryl-core-snapshot
    beryl-plugins-0.2-3.11.i586[20070522-224428] no se puede instalar debido a dependencias que no están presentes
    No hay proveedores instalables de libdbus-1.so.3 para beryl-plugins-0.2-3.11.i586[20070522-224428]
    Resolución de conflictos:
    ( ) no instalar beryl-plugins
    ( ) Omitir este requisito sólo aquí
    beryl-plugins-snapshot-r4338-3.14.i586[20070522-224428] entra en conflicto con otras resoluciones
    beryl-plugins-snapshot-r4338-3.14.i586[20070522-224428] está en conflicto con: beryl-plugins-0.2-3.11.i586[20070522-224428]

  5. abunaineko dice:

    Los problemas que aparecen allí son de dependencias de paquetes (voy a poner una guía para usar smart en vez de zen, pero eso es otro cuento) por lo pronto lo que puedes hacer es seguir los pasos que pongo en “Suse 10.2 Extras”, una vez que tengas registrados esos repositorios ya no deberás tener problemas para instalar tu beryl.
    Saludos

  6. hugo dice:

    hOLa un saludo a todos los que me estan leyendo este mensaje gracias, bueno mi problema es: yo ya instale el suse 10.2 en mi maquina y esta padre pero ahora quiero instalar ahora el beryl, y yo tengo una tarjeta de video de graficos de 256mb tengo ´problemas con estas caracteristicas…..

  7. Esteban dice:

    Hola y saludos tengo problema con beryl, hago todo lo del manual de instalacion correctamente y no funciona bien.

    Tengo suse 10.2 y una tarjeta ati que acepta la aceleracion 3D, el problema es qu al momento de iniciar beryl no funcionan el tema emerald y algunas de las funcionalides de beryl y eso me causa inestabilidad en el sistema, al momento de cargar las ventanas no aparecen las barras de arriba para mover ventanas y otras cosas mas alguien me puede ayudar

  8. Esteban dice:

    los errores que me aparecen en la consola al cargar son los siguientes

    Windows manager . waiting
    Found not compatible window manager

    cuando cargo el emerald me sale esto

    (emerald:4609): Wnck-WARNING **: Unhandled action type (nil)

    y me sale lo mismo cuando cargo el beryl kde desktop

  9. abunaineko dice:

    La descripción para la instalación es suponiendo una tarjeta con chipset nvidia, para ati te recomiendo que NO uses xgl pues según lo poco que probé cuando tube una tarjeta ati causaba algunos problemas como los que describes. Para poder usar beryl te recomiendo que mejor uses AIGLX. Si tienes duda de cómo checa la descripción de otro de los post’s de este blog.

    Saludos

  10. mateo dice:

    no se ocmo moerda instalar el cubo en el suse 10.2!!!
    es el berely?? el cubo?? porfavor alguien q me diga como hacer desde el prcipio q no entendi ala guia!1 y no puedo bajar nada de mi maquina porq no se como conedctar a suse a internet! o tengo adsl danteldata!! grax si alguien puede!!!

  11. Oscar dice:

    Hola necesito ayuda y resolver unas dudas, he investigado a ver si es posible instalar compiz-fusion en opensuse 10.2 pero parece que solo se puede a partir de la version 10.3, tambien investigue si esta disponible el beryl para instalar pero parece que los repos ya no existen alguien sabe o puede facilitarme los archivos necesarios para instalarlos sin usar Yast, por el momento uso el compiz normal que tiene opensuse 10.2, se que talvez la solucion seria usar una distro mas reciente como Ubuntu, opensuse 11.2 o Sabayon que tienen por defecto compiz-fusion, pero al menos en mi pais Costa Rica cuesta mucho conseguir una distribucion…

    Gracias y saludos amigos

    Post: uso opensuse 10.2 en un core 2 duo de 2 ghz y 4 gigas de ram con tarjeta nvidia 9700 gt..

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

Categorías
A %d blogueros les gusta esto: